Issues with email login

Incident Report for Mono Solutions

Resolved

The incident has been resolved.
Posted Jun 14, 2026 - 17:50 CEST

Monitoring

The engineering team identified an issue with our outbound mail filter that was impacting email sending. A fix has been applied and we are currently monitoring for recovery.
Posted Jun 14, 2026 - 16:37 CEST

Investigating

Our email provider is investigating some issues with the webmail.
Posted Jun 14, 2026 - 14:28 CEST
This incident affected: Third Party Products.