Issues with our email provider

Incident Report for Mono Solutions

Resolved

The issue has been resolved.
Posted Mar 10, 2026 - 18:41 CET

Investigating

Our email provider is experiencing some issues with webmail and they are investigating. https://www.opensrsstatus.com/
Posted Mar 10, 2026 - 16:34 CET
This incident affected: Third Party Products.