Issues with NS2
Incident Report for Mono Solutions
Resolved
The issue with the nameservers has been resolved.
Posted Feb 27, 2024 - 08:34 CET
Identified
We are currently experiencing some issues with our NS2, and are working to resolve the problem
Posted Feb 27, 2024 - 07:19 CET
This incident affected: Website.